SaladCloud - Billing and Credit Errors – Incident details

All systems operational

Billing and Credit Errors

Resolved
Partial outage
Started about 1 month agoLasted about 16 hours

Affected

SaladCloud

Partial outage from 5:00 AM to 9:00 PM

Portal

Partial outage from 5:00 AM to 9:00 PM

Updates
  • Resolved
    UTC
    Resolved

    A fix has been deployed.

  • Identified
    UTC
    Identified

    The vendors have identified the root cause, and we are working to get a solution deployed as quickly as possible.

  • Investigating
    UTC
    Investigating

    We are currently investigating an issue with our billing and credits integrations (Metronome and Stripe) that is preventing customers from completing purchases. Affected customers may be unable to add credits or complete new transactions.

    Our team is actively collaborating with the vendors to identify the root cause and restore full functionality as quickly as possible. We will provide updates as soon as we have meaningful progress or new information.